View Issue Details

IDProjectCategoryView StatusLast Update
0000123BirdFont[All Projects] BirdFontpublic2018-01-29 20:34
ReporterWobboAssigned Tojohan 
PriorityurgentSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
PlatformUbuntuOS15.10OS Version
Product Version 
Target VersionFixed in Version 
Summary0000123: Arabic
DescriptionFirst, Arabic font are rare and horrible to find. I can read or speak Arabic. But i need it for my project. I found out that the text looks totally different after I export the font.
Steps To ReproduceI have test it by using a working Arabic font, import it in Birdfont, not changing anything, and export it. Than I have the same problem.
Additional InformationScreenshot.
TagsNo tags attached.

Activities

Wobbo

2016-04-15 13:20

reporter  

screen.png (103,664 bytes)
screen.png (103,664 bytes)

Wobbo

2016-04-15 13:23

reporter   ~0000433

I also test it in Arial, same thing. The problem is only in IE and Safari.

johan

2016-05-14 13:30

administrator   ~0000434

Thank you for the report. The problem is that there is no backend for reading the OTF features that are essential in Arabic scripts. I would love to implement better support for Arabic script but it will take a lot of work to even get the basic things working. Hopefully will BirdFont get this capability one day but it might take a very long time.

johan

2018-01-29 20:34

administrator   ~0000492

An Arabic shaper is available in the 3.x series of BirdFont.

Issue History

Date Modified Username Field Change
2016-04-15 13:20 Wobbo New Issue
2016-04-15 13:20 Wobbo File Added: screen.png
2016-04-15 13:23 Wobbo Note Added: 0000433
2016-05-14 13:30 johan Note Added: 0000434
2018-01-29 20:34 johan Assigned To => johan
2018-01-29 20:34 johan Status new => resolved
2018-01-29 20:34 johan Resolution open => fixed
2018-01-29 20:34 johan Note Added: 0000492