View Issue Details

IDProjectCategoryView StatusLast Update
0000129BirdFont[All Projects] BirdFontpublic2016-06-05 19:01
ReporteraitorAssigned Tojohan 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMac Pro (Early 2013)OSOS XOS Version10.11.4
Product Version 
Target VersionFixed in Version 
Summary0000129: Handler of bezier curve misinterpreted when import SVG
DescriptionSome handler on some SVG are wrong interpreted by Birdfont. The attached SVG is an example. It is an "o" character and, when I try to import it, I get this glyph (instead a round "o"): http://cl.ly/1l1o2l1O3e1x

As you can see, all curves and handlers are right, except the right handler of bottom points in both paths.

The SVG is generated by Sketch app, but I can open it with Adobe Illustrator without problems (so, I think the problem is in Birdfont render).
TagsNo tags attached.

Activities

aitor

2016-06-05 18:05

reporter  

o exp.svg (1,058 bytes)

johan

2016-06-05 18:54

administrator   ~0000447

Thank you for the excellent report. I will try to fix it.

johan

2016-06-05 19:01

administrator   ~0000448

A fix for this issue is available in the git repository. It will be included in version 2.16.

Issue History

Date Modified Username Field Change
2016-06-05 18:05 aitor New Issue
2016-06-05 18:05 aitor File Added: o exp.svg
2016-06-05 18:54 johan Note Added: 0000447
2016-06-05 19:01 johan Note Added: 0000448
2016-06-05 19:01 johan Status new => resolved
2016-06-05 19:01 johan Resolution open => fixed
2016-06-05 19:01 johan Assigned To => johan