View Issue Details

IDProjectCategoryView StatusLast Update
0000105BirdFont[All Projects] BirdFontpublic2015-12-19 19:38
Reporters4448Assigned Tojohan 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSKubuntuOS Version15.10
Product Version 
Target VersionFixed in Version 
Summary0000105: Proportions locked when resizing
DescriptionI'm trying to resize a glyph horizontally, and there is a dedicated button for that, but the resize always keeps proportions, not allowing to resize in one dimension only. Is there somewhere a "lock proportions" button that I'm missing? Do I need to use a modifier key with it? Or is it just a bug?
TagsNo tags attached.

Activities

johan

2015-12-14 13:13

administrator   ~0000403

This is a missing feature. I didn't think designers need do change the proportions in this way. I might implement it for the next version.

s4448

2015-12-14 14:03

reporter   ~0000404

Thank you for the quick reply.

I would say that this is a pretty important feature.

Let me explain. Right now, I'm designing a display font with a hand-crafted brush-painted feel to it. The glyphs start on paper, are scanned and then autotraced. This results in a vector with very much detail and a lot of control points, which if I wanted to edit one-by-one would be tedious beyond imagination. And at the same time, creating the glyphs with a brush on paper, one can never get all the proportions exactly right. Those need to be adjusted in the software, after digitization. So without the ability to resize by width and height separately, BirdFont becomes a bit useless for my use case. Which is a pity, because all the other features work well, the grid workflow is really nice, and the UI is great, especially compared to something like FontForge.

My use case is also not an uncommon one. Hand-drawn fonts are vastly popular in the designer world.

And even when the typeface is not of that variety, being able to tweak the vertical and horizontal size independently is a pretty fundamental feature, which one can do without only in the most simple designs.

johan

2015-12-14 14:06

administrator   ~0000405

Sounds reasonable. I will try to implement something later today.

s4448

2015-12-14 14:16

reporter   ~0000406

Thank you very much. Keep up the good work. :)

johan

2015-12-18 00:18

administrator   ~0000407

Last edited: 2015-12-18 00:19

View 2 revisions

I have implemented this.
The code is in the git repository if you need it immediately. It will be available in version 2.15.

johan

2015-12-19 19:38

administrator   ~0000410

I believe this issue has been fixed in the latest version (2.15.3).

Issue History

Date Modified Username Field Change
2015-12-14 13:01 s4448 New Issue
2015-12-14 13:13 johan Note Added: 0000403
2015-12-14 14:03 s4448 Note Added: 0000404
2015-12-14 14:06 johan Note Added: 0000405
2015-12-14 14:16 s4448 Note Added: 0000406
2015-12-18 00:18 johan Note Added: 0000407
2015-12-18 00:19 johan Note Edited: 0000407 View Revisions
2015-12-19 19:38 johan Note Added: 0000410
2015-12-19 19:38 johan Status new => resolved
2015-12-19 19:38 johan Resolution open => fixed
2015-12-19 19:38 johan Assigned To => johan