BirdFont bugs
MantisBT
Report new issues on Github.
Anonymous | Login | Signup for a new account2017-04-25 12:41 CEST
Project:
RSS

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000125BirdFont[All Projects] BirdFontpublic2016-05-27 12:402016-06-24 12:42
Reporterchris ball 
Assigned ToJohan Mattsson 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusresolvedResolutionfixed 
Platformlenovo ideapad z565OSubuntu mateOS Version16.04
Product Version 
Target VersionFixed in Version 
Summary0000125: crash hang on file save
DescriptionSave spins forever,
no output file
Steps To Reproduceinstall bird
draw glyphs
click save
(weeping optional)
Additional Informationdebug says

** (birdfont:12789): WARNING **: GlyphCanvas.vala:85: Do not call redraw from background thread.
TagsNo tags attached.
Attached Filespng file icon Screenshot at 2016-05-27 03:24:00.png [^] (120,050 bytes) 2016-05-27 12:40

- Relationships

-  Notes
User avatar (0000441)
Johan Mattsson (administrator)
2016-05-28 12:18

Thank you for the report, this problem is new. I have not seen it and I have not been able to reproduce it yet.
User avatar (0000444)
Johan Mattsson (administrator)
2016-06-02 22:16

Does the font have many bug background images? It could be an performance issue.
(0000457)
chris ball (reporter)
2016-06-06 20:55
edited on: 2016-06-06 20:57

No images, just path splines

I think it was likely an installation foulup:
1) I tried to install from the mate gui software center... that did not work (launch icon -> no result)
2) I tried to install from apt-get... that did not work
3) I tried to follow the list of manual installs (varis, roboto etc, the (around 10 item long) list)
and still no result from icon or command line
4) after all that mess I installed the from the "debug" source on github I think it was, or sourceforge?
and then it seemed to run until I tried to save!
I've only been using linux a few months, on and off

anyway, so my ubuntu mate bf install probably needs cleaning and re-install

oh I just downloaded the osx dmg that works fine so far :)

User avatar (0000458)
Johan Mattsson (administrator)
2016-06-06 21:07

Thank you. A rare distro specific problem might explain it but I have no idea how to fix this yet. Maybe the Ubuntu Mate maintainers know.
User avatar (0000471)
Johan Mattsson (administrator)
2016-06-24 12:42

I have found an issue that likely caused this. It is a problem in GLibs main loop code. I have added a workaround in the latest version of BirdFont. The problem still exists in GLib but I have not been able to solve the issue in the library.

- Issue History
Date Modified Username Field Change
2016-05-27 12:40 chris ball New Issue
2016-05-27 12:40 chris ball File Added: Screenshot at 2016-05-27 03:24:00.png
2016-05-28 12:18 Johan Mattsson Note Added: 0000441
2016-06-02 22:16 Johan Mattsson Note Added: 0000444
2016-06-06 20:55 chris ball Note Added: 0000457
2016-06-06 20:57 chris ball Note Edited: 0000457 View Revisions
2016-06-06 21:07 Johan Mattsson Note Added: 0000458
2016-06-24 12:42 Johan Mattsson Note Added: 0000471
2016-06-24 12:42 Johan Mattsson Status new => resolved
2016-06-24 12:42 Johan Mattsson Resolution open => fixed
2016-06-24 12:42 Johan Mattsson Assigned To => Johan Mattsson


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker