View Issue Details

IDProjectCategoryView StatusLast Update
0000150BirdFont[All Projects] BirdFontpublic2018-07-24 13:56
ReporterJonnyPiggAssigned Tojohan 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000150: Apostrophe behaves like a comma unless spaced then deleted back into place.
DescriptionRight there, I'll try and get as much detail in here as possible. I've created/exported a font and all was going well until I noticed that where I'd used and apostrophe it would behave/position itself as a comma. First thought was that I'd positioned it wrong in birdfont so I went back in, checked, it look fine, typed a few things out in the spacing tab and all was well. I re-exported anyway and replaced the font where I had it (desktop and a webfont version for a site). Same thing occurred. Now, if i type I'm in illustrator it shows as I,m if I type I 'm it looks like that, then if I delete the space it's also fine. I've tried this method on the web version (I'm developing a wordpress site) but as the font doesn't show on the wysiwyg editor I can't tell if it's almost working there as when I hit update and view the page it'll be back to the comma position, although I did edit it via inspect element and that worked.

When viewing the preview (quick brown fox...) the position is right. if I type it without any other characters next to it it works. Baffling me.

I'm using a windows 7 64bit machine here (I'm in a client's office) I'm going to try exporting the font from my office where I have windows 10 64bit.
This happens in illustrator, outlook 2013 and through wordpress. I'm currently using nexusfont for font management. This is the third font I've done with birdfont, although it's the first one I've done from scratch and not started with another as a base, never seen this although I can no longer past in from illustrator, that's another not pressing issue.

Hopefully this will turn out to be making some sort of noob mistake, I look forward to feeling like a dumbass.
Thanks in advance.
Jonny
TagsNo tags attached.

Activities

JonnyPigg

2018-07-19 12:14

reporter  

apostrophe issues-01.jpg (80,557 bytes)
apostrophe issues-01.jpg (80,557 bytes)
apostrophe issues-02.jpg (11,785 bytes)
apostrophe issues-02.jpg (11,785 bytes)
apostrophe issues-03.jpg (36,829 bytes)
apostrophe issues-03.jpg (36,829 bytes)
apostrophe issues-04.jpg (39,660 bytes)
apostrophe issues-04.jpg (39,660 bytes)

JonnyPigg

2018-07-19 12:19

reporter   ~0000529

forgot to post the version, which is 3.6.4

JonnyPigg

2018-07-19 12:31

reporter   ~0000530

I've just done a quick new font with just the 3 glyphs of I ' and d. exported, added to my folder, refreshed the nexusfont folder, typed I'd in illustrator in the new font and it's fine. changed the font to the problem one and the apostrophe dropped again. madness.

johan

2018-07-19 15:59

administrator   ~0000531

Thank you for the report. Can you send e the bf file? (it is ok to e-mail it if you want to keep it private).

JonnyPigg

2018-07-19 18:00

reporter   ~0000532

cheers for reply, here's fine, still tweaking so not quite finished, got a workaround for the dev site using ′ hacky but it works for viewing.

Reveal The Peel.bf (131,621 bytes)

johan

2018-07-19 18:10

administrator   ~0000533

Could it be the case that the comma is actually what is stored in U+2019 instead of U+0027. Updating U+2019 to hold an apostrophe is probably the right thing since the UCD states that it is the preferred character to use for apostrophe.
Cheers

johan

2018-07-19 18:10

administrator   ~0000534

Nice font btw.

johan

2018-07-19 19:09

administrator   ~0000535

I suggest that you redo your kerning after you have made sure your font looks good in the spacing tab.

JonnyPigg

2018-07-19 20:36

reporter   ~0000536

cheers for checking this, I've forgot to copy the file to test at my office so I'll now have to wait til next week to check it, which is going to bug the crap out of me. Kerning recommendation noted, kept rushing it then going back to fix, then starting again, just need to simmer down and do it properly.
Again cheers for looking.

johan

2018-07-19 20:39

administrator   ~0000537

Best luck. The font is already pretty good. I am rather sure U+2019 and U+0027 will fix your problem.

JonnyPigg

2018-07-24 11:07

reporter   ~0000538

excellent, that got it. obviously wasn't paying attention when I initially set it up. glad it was something simple. nearly had a breakdown when nothing changed at first but remembered i'd installed the font as well as having it in my test folder for nexusfont.
again thank for your time.

Issue History

Date Modified Username Field Change
2018-07-19 12:13 JonnyPigg New Issue
2018-07-19 12:14 JonnyPigg File Added: apostrophe issues-01.jpg
2018-07-19 12:14 JonnyPigg File Added: apostrophe issues-02.jpg
2018-07-19 12:14 JonnyPigg File Added: apostrophe issues-03.jpg
2018-07-19 12:14 JonnyPigg File Added: apostrophe issues-04.jpg
2018-07-19 12:19 JonnyPigg Note Added: 0000529
2018-07-19 12:31 JonnyPigg Note Added: 0000530
2018-07-19 15:59 johan Note Added: 0000531
2018-07-19 18:00 JonnyPigg File Added: Reveal The Peel.bf
2018-07-19 18:00 JonnyPigg Note Added: 0000532
2018-07-19 18:10 johan Note Added: 0000533
2018-07-19 18:10 johan Note Added: 0000534
2018-07-19 19:09 johan Note Added: 0000535
2018-07-19 20:36 JonnyPigg Note Added: 0000536
2018-07-19 20:39 johan Note Added: 0000537
2018-07-24 11:07 JonnyPigg Note Added: 0000538
2018-07-24 13:56 johan Assigned To => johan
2018-07-24 13:56 johan Status new => resolved
2018-07-24 13:56 johan Resolution open => fixed