View Issue Details

IDProjectCategoryView StatusLast Update
0000157BirdFont[All Projects] BirdFontpublic2018-08-29 13:37
ReporterchandraAssigned Tojohan 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000157: Font not exporting.
DescriptionEven though the font was created under the Open Source License, BirdFont gives me the error saying a commercial license is required.
Steps To ReproduceSimply trying to export the font got me this message.
TagsNo tags attached.

Activities

chandra

2018-08-21 05:25

reporter  

bug.PNG (67,616 bytes)
bug.PNG (67,616 bytes)

johan

2018-08-21 11:21

administrator   ~0000550

Are you using the SIL OFL?

chandra

2018-08-23 06:17

reporter   ~0000551

I deeply apologise; I am very new to this entire thing. What does SIL stand for, and how do I apply this setting?

johan

2018-08-23 11:37

administrator   ~0000552

Here are the details: https://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&id=OFL

It is up to the designer of the font to choose a license.

chandra

2018-08-24 06:14

reporter   ~0000553

Thank you so much for the information.

I do select the OFL option each time Birdfont started up (I am unable to even use the application when I select the 'Commercial' version), but I still receive the error when exporting.

Is there an additional setting that needs to be changed besides the licensing option in the startup window?

Aside from my concerns here about exporting my font, I just want to let you know that Birdfont was very enjoyable to use. Thank you for the program; it must have taken a lot of dedication.

johan

2018-08-24 12:44

administrator   ~0000554

All new fonts created with the free version will be assigned SIL OFL as the license but if you open a font created by another designer will Birdfont not change the license and you can't export if the designer choose a license other than the SIL OFL.

chandra

2018-08-25 17:10

reporter   ~0000555

I created the font from scratch by myself. Attached is the project file.

chandra

2018-08-25 17:11

reporter  

font.bf (360,341 bytes)

johan

2018-08-25 17:17

administrator   ~0000556

Nice font!

There was a typo in the license field. Here is a fix for this.

font-2.bf (360,309 bytes)

chandra

2018-08-26 05:26

reporter   ~0000557

Oh, wow! Thank you so much for fixing that; the export works, now! :D Thank you, thank you! I cannot wait to use my new font.

I apologize, but I have another question.

In the Birdfont editor, the letters are all lined up accordingly, but after I exported my font and tested it in other programs, my 'h' glyph seems to be malfunctioning (both with the OpenType and TrueType file); characters following the 'h' are inserted to the left of the character instead of the right. This causes overlapping characters, and I was wondering if you could help me adjust my 'h' glyph to remove this problem.

Thank you so much, once again, for your generous help. Alas I am not old enough for a Paypal account yet, but when I do get one, I will be sure to donate to your amazing project.

photoshop.PNG (182,921 bytes)
photoshop.PNG (182,921 bytes)
word.PNG (79,520 bytes)
word.PNG (79,520 bytes)
font-2-2.bf (360,311 bytes)

chandra

2018-08-26 05:28

reporter   ~0000558

Additionally, this is what my installation window looked like for the font. I noticed that there is a very, very large gap between the 'h' and 'i' glyphs.

johan

2018-08-26 12:03

administrator   ~0000559

It looks like the right marker is placed to the left of the glyph and vice versa. Try swapping them.
Cheers

chandra

2018-08-26 23:39

reporter  

thank you.PNG (132,627 bytes)
thank you.PNG (132,627 bytes)

Issue History

Date Modified Username Field Change
2018-08-21 05:25 chandra New Issue
2018-08-21 05:25 chandra File Added: bug.PNG
2018-08-21 11:21 johan Note Added: 0000550
2018-08-23 06:17 chandra Note Added: 0000551
2018-08-23 11:37 johan Note Added: 0000552
2018-08-24 06:14 chandra Note Added: 0000553
2018-08-24 12:44 johan Note Added: 0000554
2018-08-25 17:10 chandra Note Added: 0000555
2018-08-25 17:11 chandra File Added: font.bf
2018-08-25 17:17 johan File Added: font-2.bf
2018-08-25 17:17 johan Note Added: 0000556
2018-08-26 05:26 chandra File Added: photoshop.PNG
2018-08-26 05:26 chandra File Added: word.PNG
2018-08-26 05:26 chandra File Added: font-2-2.bf
2018-08-26 05:26 chandra Note Added: 0000557
2018-08-26 05:28 chandra File Added: Installation screenshot.PNG
2018-08-26 05:28 chandra Note Added: 0000558
2018-08-26 12:03 johan Note Added: 0000559
2018-08-26 23:39 chandra File Added: thank you.PNG
2018-08-29 13:37 johan Assigned To => johan
2018-08-29 13:37 johan Status new => resolved
2018-08-29 13:37 johan Resolution open => fixed