View Issue Details

IDProjectCategoryView StatusLast Update
0000158BirdFont[All Projects] BirdFontpublic2018-10-11 18:39
ReporterMath42Assigned Tojohan 
PriorityimmediateSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000158: Exort problem
DescriptionIn BirdFont the font appear to be OK but,
When exporting in ttf or off
the path of 2 or 3 glyphs are distorted
and when I close the file and open it anew (the .bf) the font is not ok, it's distorted
TagsNo tags attached.

Activities

Math42

2018-10-04 14:56

reporter   ~0000560

I have to finish my job today and I'm stressed by that !

johan

2018-10-04 14:57

administrator   ~0000561

Than you for the report. Can you send me your files? Both the distorted and undistributed could be very useful for debugging.
It is OK to send the files to my e-mail address if you don't want them to become public.
Cheers

Math42

2018-10-04 14:58

reporter   ~0000562

the . bf file here

Anamath2.bf (1,053,676 bytes)

Math42

2018-10-04 15:00

reporter   ~0000563

there is a problem with the 8, the o and the R, and before with the b...

johan

2018-10-04 15:14

administrator   ~0000564

Thank you. I will try to fix this when I get Home. It will take a few hours, I appologize for the delay.

johan

2018-10-04 15:34

administrator   ~0000565

Which OS do you have an which version of your OS are you using.

Math42

2018-10-04 15:38

reporter   ~0000566

OSX 10.13.6
I partially fix the problem using the command "Create counter from outline" !?

johan

2018-10-04 15:41

administrator   ~0000567

Thank you for the update. I have certainly not heard of anything like this before.

johan

2018-10-04 18:48

administrator   ~0000568

I believe this problem comes from either an error in the SVG import or an error in opening an OTF file. I cant see any glyphs in your BF file that changes when I export; probably because the distortion have already happened. The problem however is connected to point types. A point in the path has been changed from its cubic to quadratic form, you can change the point type manually and fix the error but I would prefer if you help me with fixing this issue, either way. Can you send me the OTF or SVG version this font?

Math42

2018-10-04 18:52

reporter   ~0000569

Here you have all the latest files that seem to be correct

AnamathStencil-Book Mac.otf (489,760 bytes)
AnamathStencil-Book Mac.ttf (254,756 bytes)
AnamathStencil-Book.eot (254,856 bytes)
AnamathStencil-Book.otf (489,760 bytes)
AnamathStencil-Book.svg (512,001 bytes)
AnamathStencil-Book.ttf (254,756 bytes)
anaphora-MATH2.bf (1,053,094 bytes)

johan

2018-10-04 21:03

administrator   ~0000570

I believe this problem has been fixed in 3.12.10 for Mac OS X. Can you test this and report back?

Issue History

Date Modified Username Field Change
2018-10-04 14:54 Math42 New Issue
2018-10-04 14:56 Math42 Note Added: 0000560
2018-10-04 14:57 johan Note Added: 0000561
2018-10-04 14:58 Math42 File Added: Anamath2.bf
2018-10-04 14:58 Math42 Note Added: 0000562
2018-10-04 15:00 Math42 Note Added: 0000563
2018-10-04 15:14 johan Note Added: 0000564
2018-10-04 15:34 johan Note Added: 0000565
2018-10-04 15:38 Math42 Note Added: 0000566
2018-10-04 15:41 johan Note Added: 0000567
2018-10-04 18:48 johan Note Added: 0000568
2018-10-04 18:52 Math42 File Added: AnamathStencil-Book Mac.otf
2018-10-04 18:52 Math42 File Added: AnamathStencil-Book Mac.ttf
2018-10-04 18:52 Math42 File Added: AnamathStencil-Book.eot
2018-10-04 18:52 Math42 File Added: AnamathStencil-Book.otf
2018-10-04 18:52 Math42 File Added: AnamathStencil-Book.svg
2018-10-04 18:52 Math42 File Added: AnamathStencil-Book.ttf
2018-10-04 18:52 Math42 File Added: anaphora-MATH2.bf
2018-10-04 18:52 Math42 Note Added: 0000569
2018-10-04 21:03 johan Note Added: 0000570
2018-10-11 18:39 johan Assigned To => johan
2018-10-11 18:39 johan Status new => resolved
2018-10-11 18:39 johan Resolution open => fixed