View Issue Details

IDProjectCategoryView StatusLast Update
0000159BirdFont[All Projects] BirdFontpublic2018-12-20 17:09
ReporterThe Mouse AvengerAssigned Tojohan 
PriorityurgentSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSWindowsOS Version7
Product Version 
Target VersionFixed in Version 
Summary0000159: Birdfont stalls, doesn't respond, & crashes when I try to import PNG
DescriptionI installed Birdfont this afternoon, & after some preliminary exploration of the software, I tried to import a PNG file as a background image for reference while working on a new font. At first, everything seemed to be going smoothly when I started progressing through a path of folders in my Documents to the one that contained the PNG file I wanted to import...but about halfway through, when one of the folders was trying to load, Birdfont froze & stopped responding. I closed out Birdfont, then opened it back up, & tried to import the PNG file again...but this time, I couldn't even load any of the computer folders, before the program froze & stopped responding again! I tried this whole process again a few more times after uninstalling & reinstalling Birdfont, but to no avail. :-( Please, can someone fix this bug, or otherwise solve this problem for me? Any assistance would be greatly appreciated! :-)

P.S.: I included a copy of the PNG file that I'm trying to import as a background image.
TagsNo tags attached.

Activities

The Mouse Avenger

2018-10-26 03:10

reporter  

johan

2018-10-26 14:12

administrator   ~0000572

Thank you for your report. I will try to reproduce this. Are you using version 3.12.10?

johan

2018-10-26 17:02

administrator   ~0000573

Last edited: 2018-10-26 17:03

View 2 revisions

I have tried a few things but I did not manage to find a way to crash birdfont. Can you send me the settings file for birdfont? You can find it here:
C:\Users\your user name\AppData\Local\birdfont the file has the name settings.

The Mouse Avenger

2018-10-26 17:06

reporter   ~0000574

I'm using 3.14.3. :-) Thanks again!

johan

2018-10-26 17:10

administrator   ~0000575

Thank you for the update. Can you attach the settings file?

The Mouse Avenger

2018-10-26 19:46

reporter   ~0000576

Where do I find it? :-?

johan

2018-10-26 19:50

administrator   ~0000577

C:\Users\your user name\AppData\Local\birdfont the file has the name settings.

The Mouse Avenger

2018-10-26 20:26

reporter   ~0000578

OK, thanks! ^_^ I found it, & here it is! :-)

settings (109 bytes)
# BirdFont settings
# Version: 1.0
theme "dark.theme"
last_file "C:\msys32\home\johan/.bf"
theme_version "1"
settings (109 bytes)

johan

2018-10-26 20:44

administrator   ~0000579

Thank you. Can you try deleting it and running birdfont again?

The Mouse Avenger

2018-10-26 20:49

reporter   ~0000580

I suppose I could. :-)

The Mouse Avenger

2018-10-26 20:55

reporter   ~0000581

(tries again after deleting the settings file, but the same problem occurs)

No, it didn't work. :-(

johan

2018-10-26 20:59

administrator   ~0000582

Thank you. Does the problem occur if you create a new font as well?

The Mouse Avenger

2018-10-26 21:21

reporter   ~0000583

Yes, it does, I'm afraid. :-(

johan

2018-10-26 22:10

administrator   ~0000584

I have not heard of anything like this before. Can you generate a log file and send it to me? Here are the steps to do that:
1. Open the Windows terminal: search for cmd
2. Go to the Birdfont program folder: cd "C:\Program Files (x86)\Birdfont" (or another folder if you have installed Birdfont in another location).
3. Run birdfont.exe --log
4. Open a font in Birdfont
5. Send me the log file, it should appear in C:\Users\Your User Name\AppData\Local\birdfont

The Mouse Avenger

2018-10-26 23:28

reporter   ~0000585

It might be a little easier for me to follow all those instructions if I had a visual guide, like screenshots of all the individual steps--I'm kinda paranoid about accidentally messing something up on my computer, since I've never done this kind of thing before. ^^;; Thanks again!

johan

2018-10-27 00:00

administrator   ~0000586

I have attached a screenshot for each step.
Cheers

Screenshots.zip (2,852,693 bytes)

The Mouse Avenger

2018-10-27 00:11

reporter   ~0000587

Thanks a bunch! (goes to open the file, & look at the screenshots)

I'll tell you how it goes. :-)

The Mouse Avenger

2018-10-27 00:54

reporter   ~0000588

I followed all the steps, & tried again, but the log file didn't even generate. :-(

johan

2018-10-27 00:57

administrator   ~0000589

Thank you for the update. I will write better code for generating log files tomorrow.

The Mouse Avenger

2018-10-27 01:17

reporter   ~0000590

Thank you! :-) Is there anything you can do to fix the freezing, crashing, & unsuccessful importing of PNG background images, too?

The Mouse Avenger

2018-10-27 19:35

reporter   ~0000591

So, how goes the bug-fixing, Mr. Johan :-) All well?

johan

2018-10-27 19:38

administrator   ~0000592

Hi

I have not managed to reproduce the problem but I hope you can help me with some testing when the new logging system is in place.

The Mouse Avenger

2018-10-27 21:20

reporter   ~0000593

Okay, will do! ^_^

johan

2018-10-27 21:58

administrator   ~0000594

Hi
The compilation seems to take forever on my older rig but I have finally managed to create a version with GUI support for creating log files.
See: https://birdfont.org/download/birdfont-3.14.4-free.exe

Please open settings, click on "Write log to ..." and send me the log file.

Cheers

The Mouse Avenger

2018-10-28 02:17

reporter   ~0000595

OK, thanks! ^_^ Will do!

(goes off to do so)

The Mouse Avenger

2018-10-28 02:46

reporter   ~0000596

I clicked on the new setting to allow Birdfont to send a log file, but it didn't make one when I tried importing the PNG file again. :-( Also, the setting says, "Write file to C:\Users\USER\AppData\Local\birdfont\birdfont_timestamp.log", but I don't have an AppData folder, or any of the subfolders, on my hard drive. :-( What should we do now?

johan

2018-10-28 13:16

administrator   ~0000597

Here's how to show the AppData folder in Windows.

    Go to Windows Explorer.
    Open the C: drive.
    Click Organize on the menu bar.
    Select Folder and Search options.
    Select the View tab.
    Under Files and Folders > Hidden files and folders, select the option to Show hidden files, folders and drives.
    Click OK.

johan

2018-11-03 16:34

administrator   ~0000598

Last edited: 2018-11-05 20:15

View 2 revisions

Hi
Have you found the log file?

The Mouse Avenger

2018-11-22 14:32

reporter   ~0000602

I believe I have! :D

birdfont_2018-11-22T07_27_20-0600.log (2,466 bytes)

johan

2018-11-22 19:12

administrator   ~0000603

Thank you. The log file does not contain data from a crash. It looks like birdfont did exit normally this time. Can you send me a new log file from a session where the program crashes?

The Mouse Avenger

2018-11-24 23:47

reporter   ~0000604

Don't worry, I have that, too. :-)

birdfont_2018-11-24T16_39_29-0600.log (2,923 bytes)

johan

2018-11-25 12:09

administrator   ~0000605

Last edited: 2018-11-25 12:10

View 2 revisions

Thank you. Can you send me a screenshot of all files in the folder? (C:\Users\USER\Documents\Sorting Folder)

The Mouse Avenger

2018-11-26 04:10

reporter   ~0000606

Well, there's a LOT of those...& I do mean a LOT! XD What do you suggest I do? :-)

johan

2018-11-26 10:56

administrator   ~0000607

It might be the case that the huge number of files in the folder slows down the process and causes BirdFont to work for a really long time processing the folder. A way around it might be to paste the full path into the text field. I will try to come up with a solution.

The Mouse Avenger

2018-11-27 23:00

reporter   ~0000608

Oh, thank you! ^_^ Thank you so very much! :D Do let me know when you've done it, will you? :-)

johan

2018-11-29 15:10

administrator   ~0000609

Have you tried moving the image in question to its own folder?

The Mouse Avenger

2018-12-03 05:03

reporter   ~0000610

Oh, no, I haven't. Anyway, I'm curious as to what your ideas to fix the bug might be. :-)

johan

2018-12-03 14:02

administrator   ~0000611

I believe that speed optimization might be a way to fix this but I am not sure yet. Switching to Windows 10 is also an option :).

The Mouse Avenger

2018-12-10 13:02

reporter   ~0000612

Speed optimization sounds great! ^_^ Also, perhaps, getting the program to open via the traditional "Open File" Windows dialogue might help, too. :-) Could you possibly arrange that?

johan

2018-12-10 13:07

administrator   ~0000613

The Windows default dialog is available in the version for Windows 10, I suggest that you upgrade your OS. �

johan

2018-12-10 13:08

administrator   ~0000614

The Windows 10 version is also quite a lot faster than the version for old Windows installations.

The Mouse Avenger

2018-12-12 03:25

reporter   ~0000615

On second thought, I'd be content just to have the speed optimization. :-) I mean, as long as I can get it to work, it's fine, really!

The Mouse Avenger

2018-12-14 23:29

reporter   ~0000616

Could you please let me know when you've fixed the speed optimization, so I can try again? :-) Many, many thanks! ^_^

johan

2018-12-14 23:31

administrator   ~0000617

Yes. Can you try to move the file into its own folder? If that works is the problem probably connected to low performance in the file dialog.

The Mouse Avenger

2018-12-15 19:31

reporter   ~0000618

Sure, I can do that. :-) I'll let you know how it goes!

johan

2018-12-17 14:00

administrator   ~0000619

I have released a new version that might solve the problem you have found. Please test version 3.18 and let me know how it goes.

The Mouse Avenger

2018-12-20 15:37

reporter   ~0000620

OK, sure thing! ^_^

The Mouse Avenger

2018-12-20 17:07

reporter   ~0000621

Yes! :D It worked! ^_^ By Jove, it worked! :D Thank you, thank you so much! :-) You're a genius! ^_^

johan

2018-12-20 17:09

administrator   ~0000622

Thank you for the testing!

Issue History

Date Modified Username Field Change
2018-10-26 03:10 The Mouse Avenger New Issue
2018-10-26 03:10 The Mouse Avenger File Added: the_great_mouse_detective_-_title_logo.png
2018-10-26 14:12 johan Note Added: 0000572
2018-10-26 17:02 johan Note Added: 0000573
2018-10-26 17:03 johan Note Edited: 0000573 View Revisions
2018-10-26 17:06 The Mouse Avenger Note Added: 0000574
2018-10-26 17:10 johan Note Added: 0000575
2018-10-26 19:46 The Mouse Avenger Note Added: 0000576
2018-10-26 19:50 johan Note Added: 0000577
2018-10-26 20:26 The Mouse Avenger File Added: settings
2018-10-26 20:26 The Mouse Avenger Note Added: 0000578
2018-10-26 20:44 johan Note Added: 0000579
2018-10-26 20:49 The Mouse Avenger Note Added: 0000580
2018-10-26 20:55 The Mouse Avenger Note Added: 0000581
2018-10-26 20:59 johan Note Added: 0000582
2018-10-26 21:21 The Mouse Avenger Note Added: 0000583
2018-10-26 22:10 johan Note Added: 0000584
2018-10-26 23:28 The Mouse Avenger Note Added: 0000585
2018-10-27 00:00 johan File Added: Screenshots.zip
2018-10-27 00:00 johan Note Added: 0000586
2018-10-27 00:11 The Mouse Avenger Note Added: 0000587
2018-10-27 00:54 The Mouse Avenger Note Added: 0000588
2018-10-27 00:57 johan Note Added: 0000589
2018-10-27 01:17 The Mouse Avenger Note Added: 0000590
2018-10-27 19:35 The Mouse Avenger Note Added: 0000591
2018-10-27 19:38 johan Note Added: 0000592
2018-10-27 21:20 The Mouse Avenger Note Added: 0000593
2018-10-27 21:58 johan Note Added: 0000594
2018-10-28 02:17 The Mouse Avenger Note Added: 0000595
2018-10-28 02:46 The Mouse Avenger Note Added: 0000596
2018-10-28 13:16 johan Note Added: 0000597
2018-11-03 16:34 johan Note Added: 0000598
2018-11-05 20:15 johan Note Edited: 0000598 View Revisions
2018-11-22 14:32 The Mouse Avenger File Added: birdfont_2018-11-22T07_27_20-0600.log
2018-11-22 14:32 The Mouse Avenger Note Added: 0000602
2018-11-22 19:12 johan Note Added: 0000603
2018-11-24 23:47 The Mouse Avenger File Added: birdfont_2018-11-24T16_39_29-0600.log
2018-11-24 23:47 The Mouse Avenger Note Added: 0000604
2018-11-25 12:09 johan Note Added: 0000605
2018-11-25 12:10 johan Note Edited: 0000605 View Revisions
2018-11-26 04:10 The Mouse Avenger Note Added: 0000606
2018-11-26 10:56 johan Note Added: 0000607
2018-11-27 23:00 The Mouse Avenger Note Added: 0000608
2018-11-29 15:10 johan Note Added: 0000609
2018-12-03 05:03 The Mouse Avenger Note Added: 0000610
2018-12-03 14:02 johan Note Added: 0000611
2018-12-10 13:02 The Mouse Avenger Note Added: 0000612
2018-12-10 13:07 johan Note Added: 0000613
2018-12-10 13:08 johan Note Added: 0000614
2018-12-12 03:25 The Mouse Avenger Note Added: 0000615
2018-12-14 23:29 The Mouse Avenger Note Added: 0000616
2018-12-14 23:31 johan Note Added: 0000617
2018-12-15 19:31 The Mouse Avenger Note Added: 0000618
2018-12-17 14:00 johan Note Added: 0000619
2018-12-20 15:37 The Mouse Avenger Note Added: 0000620
2018-12-20 17:07 The Mouse Avenger Note Added: 0000621
2018-12-20 17:09 johan Assigned To => johan
2018-12-20 17:09 johan Status new => resolved
2018-12-20 17:09 johan Resolution open => fixed
2018-12-20 17:09 johan Note Added: 0000622