View Issue Details

IDProjectCategoryView StatusLast Update
0000044BirdFont[All Projects] BirdFontpublic2014-09-27 20:09
ReporterrodeloliAssigned Tojohan 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSXubuntuOS Version14.04
Product Version 
Target VersionFixed in Version 
Summary0000044: Error while loading shared libraries: libbirdfont.so.26.0
DescriptionI have downloaded the 1.4 commercial version and installed Birdfont from source code with all dependencies satisfied. When trying to open the launcher nothing happens and when I tried to open it from terminal it gives me the following error message.

$ birdfont
birdfont: error while loading shared libraries: libbirdfont.so.26.0: cannot open shared object file: No such file or directory
Steps To ReproduceOpen Whisker menu
Click on Birdfont launcher
Nothing happen

-------------------------

Open terminal
Type birdfont
Error happens
TagsNo tags attached.

Activities

johan

2014-09-25 14:15

administrator   ~0000167

did you run ldconfig after calling install.py?

rodeloli

2014-09-25 14:42

reporter   ~0000168

Last edited: 2014-09-25 14:43

View 3 revisions

I did that after reading your note. Also tried reinstalling again with both build methods (linux_build.py & doit) Continues returning the same error.

johan

2014-09-25 14:47

administrator   ~0000169

Last edited: 2014-09-25 14:54

View 2 revisions

I did just try to install and run birdfont on ubuntu 14 it works for me.
Can you start birdfont from the birdfont.sh shell script in the source folder?
What does your scripts/config.py look like?

rodeloli

2014-09-25 15:05

reporter   ~0000170

Yes it works when I started birdfont.sh from terminal.

The config.py:

#!/usr/bin/python
PREFIX = "/usr"
DEST = ""
CC = "gcc"
GEE = "gee-1.0"

johan

2014-09-25 15:07

administrator   ~0000171

Thank you.
Does the library exist in /usr/lib? What does "ls /usr/lib/libbird*" say?

rodeloli

2014-09-25 15:12

reporter   ~0000172

ls: cannot access /usr/lib/libbird: No such file or directory

johan

2014-09-25 15:14

administrator   ~0000173

Good.
What messages do you see when you run "sudo ./install.py"?

rodeloli

2014-09-25 15:18

reporter   ~0000174

install: /usr/share/birdfont/layout/birdfont.rc
install: /usr/share/birdfont/icons/export_fonts.png
install: /usr/share/birdfont/icons/kerning_text_input.png
install: /usr/share/birdfont/icons/zoom_tool.png
install: /usr/share/birdfont/icons/pen_tool.png
install: /usr/share/birdfont/icons/tab1_left.png
install: /usr/share/birdfont/icons/point_tool.png
install: /usr/share/birdfont/icons/kerning_class.png
install: /usr/share/birdfont/icons/selected_edit_point_handle.png
install: /usr/share/birdfont/icons/track.png
install: /usr/share/birdfont/icons/edit_point_cubic.png
install: /usr/share/birdfont/icons/symmetric.png
install: /usr/share/birdfont/icons/scale_background.png
install: /usr/share/birdfont/icons/convert_point.png
install: /usr/share/birdfont/icons/tool_button_selected_active.png
install: /usr/share/birdfont/icons/move_canvas.png
install: /usr/share/birdfont/icons/autotrace.png
install: /usr/share/birdfont/icons/double_points.png
install: /usr/share/birdfont/icons/close_paths.png
install: /usr/share/birdfont/icons/next_tab.png
install: /usr/share/birdfont/icons/flip_horizontal.png
install: /usr/share/birdfont/icons/new_point_on_path.png
install: /usr/share/birdfont/icons/active_edit_point_handle.png
install: /usr/share/birdfont/icons/delete_selected_glyph.png
install: /usr/share/birdfont/icons/high_contrast_background.png
install: /usr/share/birdfont/icons/version.png
install: /usr/share/birdfont/icons/cut_background.png
install: /usr/share/birdfont/icons/move_layer.png
install: /usr/share/birdfont/icons/zoom_1_1.png
install: /usr/share/birdfont/icons/corner.png
install: /usr/share/birdfont/icons/generate_html_document.png
install: /usr/share/birdfont/icons/active_selected_edit_point.png
install: /usr/share/birdfont/icons/reverse_path.png
install: /usr/share/birdfont/icons/slow_test.png
install: /usr/share/birdfont/icons/selected_edit_point_cubic.png
install: /usr/share/birdfont/icons/new_grid.png
install: /usr/share/birdfont/icons/view_result.png
install: /usr/share/birdfont/icons/tool_button_selected.png
install: /usr/share/birdfont/icons/flip_vertical.png
install: /usr/share/birdfont/icons/zoom_boundaries.png
install: /usr/share/birdfont/icons/create_line.png
install: /usr/share/birdfont/icons/delete_menu_item.png
install: /usr/share/birdfont/icons/new_point.png
install: /usr/share/birdfont/icons/tab_bar_background.png
install: /usr/share/birdfont/icons/edit_point_handle.png
install: /usr/share/birdfont/icons/x_coordinate.png
install: /usr/share/birdfont/icons/tool_button_deselected.png
install: /usr/share/birdfont/icons/undo_tool.png
install: /usr/share/birdfont/icons/insert_point_on_path.png
install: /usr/share/birdfont/icons/fill_open_path.png
install: /usr/share/birdfont/icons/zoom_in.png
install: /usr/share/birdfont/icons/auto_trace_resolution.png
install: /usr/share/birdfont/icons/width.png
install: /usr/share/birdfont/icons/insert_background.png
install: /usr/share/birdfont/icons/active_selected_edit_point_cubic.png
install: /usr/share/birdfont/icons/skew.png
install: /usr/share/birdfont/icons/insert_last_glyph.png
install: /usr/share/birdfont/icons/move_point.png
install: /usr/share/birdfont/icons/circle.png
install: /usr/share/birdfont/icons/no_icon.png
install: /usr/share/birdfont/icons/zoom_out.png
install: /usr/share/birdfont/icons/select_all.png
install: /usr/share/birdfont/icons/tab3_left.png
install: /usr/share/birdfont/icons/delete_button.png
install: /usr/share/birdfont/icons/tie_is_active.png
install: /usr/share/birdfont/icons/ttf_units.png
install: /usr/share/birdfont/icons/new_file.png
install: /usr/share/birdfont/icons/progress_wheel.png
install: /usr/share/birdfont/icons/show_xheight_helplines.png
install: /usr/share/birdfont/icons/custom_character_set.png
install: /usr/share/birdfont/icons/rectangle.png
install: /usr/share/birdfont/icons/tab2_right.png
install: /usr/share/birdfont/icons/full_glyph.png
install: /usr/share/birdfont/icons/next.png
install: /usr/share/birdfont/icons/height.png
install: /usr/share/birdfont/icons/cubic_points.png
install: /usr/share/birdfont/icons/resize.png
install: /usr/share/birdfont/icons/utf_8.png
install: /usr/share/birdfont/icons/window_icon.png
install: /usr/share/birdfont/icons/available_characters.png
install: /usr/share/birdfont/icons/test_case.png
install: /usr/share/birdfont/icons/tab1_right.png
install: /usr/share/birdfont/icons/help_lines.png
install: /usr/share/birdfont/icons/add_new_grid.png
install: /usr/share/birdfont/icons/active_edit_point_cubic.png
install: /usr/share/birdfont/icons/spin_button.png
install: /usr/share/birdfont/icons/move_background.png
install: /usr/share/birdfont/icons/tab2_left.png
install: /usr/share/birdfont/icons/show_all_line_handles.png
install: /usr/share/birdfont/icons/resize_handle.png
install: /usr/share/birdfont/icons/tool_button_deselected_active.png
install: /usr/share/birdfont/icons/rotation.png
install: /usr/share/birdfont/icons/add_background_image.png
install: /usr/share/birdfont/icons/cancel_save.png
install: /usr/share/birdfont/icons/previous_tab.png
install: /usr/share/birdfont/icons/background_help_lines.png
install: /usr/share/birdfont/icons/quadratic_points.png
install: /usr/share/birdfont/icons/tab3_right.png
install: /usr/share/birdfont/icons/tie_point.png
install: /usr/share/birdfont/icons/auto_trace_simplify.png
install: /usr/share/birdfont/icons/contrast_threshold.png
install: /usr/share/birdfont/icons/side_bearings.png
install: /usr/share/birdfont/icons/info_icon.png
install: /usr/share/birdfont/icons/selected_edit_point.png
install: /usr/share/birdfont/icons/test_icon.png
install: /usr/share/birdfont/icons/update_webview.png
install: /usr/share/birdfont/icons/edit_point.png
install: /usr/share/birdfont/icons/prev.png
install: /usr/share/birdfont/icons/union_paths.png
install: /usr/share/birdfont/icons/active_edit_point.png
install: /usr/share/birdfont/icons/y_coordinate.png
install: /usr/share/birdfont/icons/show_background.png
install: /usr/share/birdfont/icons/move.png
install: /usr/share/birdfont/icons/zoom_background_image.png
install: /usr/share/applications/birdfont.desktop
install: /usr/share/icons/hicolor/128x128/apps/birdfont.png
install: /usr/share/icons/hicolor/48x48/apps/birdfont.png
install: /usr/share/appdata//birdfont.appdata.xml
install: /usr/bin/birdfont
install: /usr/bin/birdfont-autotrace
install: /usr/bin/birdfont-export
install: /usr/bin/birdfont-import
install: /usr/lib64/libbirdfont.so.26.0
install link: /usr/lib64/ libbirdfont.so.26
install link: /usr/lib64/ libbirdfont.so
install: /usr/man/man1/birdfont.1.gz
install: /usr/man/man1/birdfont-autotrace.1.gz
install: /usr/man/man1/birdfont-export.1.gz
install: /usr/man/man1/birdfont-import.1.gz
install: /usr/share/locale/el/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/oc/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/nb/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/tr/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/it/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/pt/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/fr/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/sk/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/sr/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/fa/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/ja/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/cs/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/es/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/de/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/zh_CN/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/uk/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/nl/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/pl/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/ru/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/sv/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/he/LC_MESSAGES/birdfont.mo
install: /usr/share/locale/pt_BR/LC_MESSAGES/birdfont.mo
install: /usr/share/mime/packages/birdfont.xml

johan

2014-09-25 15:23

administrator   ~0000175

Last edited: 2014-09-25 15:23

View 2 revisions

Thank you it looks like the file ended up in lib64, I still run 32 bit which explains why I could not reproduce this. I don't know how to fix this yet but I will do a bit of googling.

rodeloli

2014-09-25 15:45

reporter   ~0000176

I hope this help to solve the issue.
I also have the 32 libs installed in my OS which makes it more strange.
Anyway, I'm dying to use this software and contribute to the development (financially I mean).
Good job so far, I really like the simplicity of the interface and all the features.

johan

2014-09-25 16:20

administrator   ~0000177

Last edited: 2014-09-25 16:45

View 4 revisions

After reading a bit about multiarch support in debian and ubuntu do I believe that the library should be installed in "/usr/lib/$(dpkg-architecture -qDEB_HOST_MULTIARCH)/". What happens if you run "sudo cp build/libbirdfont.so.26.0 /usr/lib/$(dpkg-architecture -qDEB_HOST_MULTIARCH)/"?

rodeloli

2014-09-25 23:35

reporter   ~0000179

sudo cp build/libbirdfont.so.26.0 /usr/lib/$(dpkg-architecture -qDEB_HOST_MULTIARCH)/

cp: cannot stat ‘build/libbirdfont.so.26.0’: No such file or directory

johan

2014-09-26 07:41

administrator   ~0000180

sorry, it should be: "sudo cp build/bin/libbirdfont.so.26.0 /usr/lib/$(dpkg-architecture -qDEB_HOST_MULTIARCH)/"

johan

2014-09-27 20:09

administrator   ~0000184

I believe this issue has been fixed in version 1.5. Please add a note if you still get errors in the new version.

Issue History

Date Modified Username Field Change
2014-09-25 13:50 rodeloli New Issue
2014-09-25 14:15 johan Note Added: 0000167
2014-09-25 14:42 rodeloli Note Added: 0000168
2014-09-25 14:43 rodeloli Note Edited: 0000168 View Revisions
2014-09-25 14:43 rodeloli Note Edited: 0000168 View Revisions
2014-09-25 14:47 johan Note Added: 0000169
2014-09-25 14:54 johan Note Edited: 0000169 View Revisions
2014-09-25 15:05 rodeloli Note Added: 0000170
2014-09-25 15:07 johan Note Added: 0000171
2014-09-25 15:12 rodeloli Note Added: 0000172
2014-09-25 15:14 johan Note Added: 0000173
2014-09-25 15:18 rodeloli Note Added: 0000174
2014-09-25 15:23 johan Note Added: 0000175
2014-09-25 15:23 johan Note Edited: 0000175 View Revisions
2014-09-25 15:45 rodeloli Note Added: 0000176
2014-09-25 16:20 johan Note Added: 0000177
2014-09-25 16:21 johan Note Edited: 0000177 View Revisions
2014-09-25 16:30 johan Note Edited: 0000177 View Revisions
2014-09-25 16:45 johan Note Edited: 0000177 View Revisions
2014-09-25 16:45 johan Assigned To => johan
2014-09-25 16:45 johan Status new => confirmed
2014-09-25 23:35 rodeloli Note Added: 0000179
2014-09-26 07:41 johan Note Added: 0000180
2014-09-27 20:09 johan Note Added: 0000184
2014-09-27 20:09 johan Status confirmed => resolved
2014-09-27 20:09 johan Resolution open => fixed