View Issue Details

IDProjectCategoryView StatusLast Update
0000058BirdFont[All Projects] BirdFontpublic2015-03-05 13:19
ReporterTu canAssigned Tojohan 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformMac osOSOS Version10.9.5
Product Version 
Target VersionFixed in Version 
Summary0000058: cannot import svg files
DescriptionWhen I try to import a SVG file (created with Adobe Illustrator cs6) nothing appears in Birdfont. Copy&paste did not work either.

I tried the same in Birdfont version 1.1 because I remembered that ist worked there... here the svg appears but all messed up (see screenshot below)

Do I have to sve the svg with some special settings to import it?
TagsNo tags attached.

Activities

Tu can

2014-12-22 13:22

reporter  

Tu can

2014-12-22 13:25

reporter  

svg_template-digatusLogo2-01.svg (35,465 bytes)

johan

2014-12-23 16:13

administrator   ~0000229

Thank you for the report. I will try to fix it.

johan

2014-12-24 01:00

administrator  

Digatus.bf (11,540 bytes)

johan

2014-12-24 01:03

administrator   ~0000230

I think I found the bugs and I will release a version with the fixes as soon as possible. Thanks a lot for reporting this issue! SVG import is a very important functionality and I don't have Illustrator to do the testing.

johan

2014-12-24 01:05

administrator   ~0000231

I have uploaded a font with the SVG file imported — I think it looks right but please add a comment if you find more problems with the SVG import.

Tu can

2015-01-07 11:46

reporter   ~0000232

Thank you very much! your version looks perfect.
But how did you do that? When I try to import a svg it still turns out messed up or in most cases does not appear at all....

johan

2015-01-14 10:32

administrator   ~0000233

I have created a new version of BirdFont that fixes the bug. I will release it soon.

johan

2015-03-05 13:19

administrator   ~0000257

This issue has been solved for the 2.0 branch.

Issue History

Date Modified Username Field Change
2014-12-22 13:22 Tu can New Issue
2014-12-22 13:22 Tu can File Added: Bildschirmfoto 2014-12-22 um 13.18.47.png
2014-12-22 13:25 Tu can File Added: svg_template-digatusLogo2-01.svg
2014-12-23 16:13 johan Note Added: 0000229
2014-12-24 01:00 johan File Added: Digatus.bf
2014-12-24 01:03 johan Note Added: 0000230
2014-12-24 01:05 johan Note Added: 0000231
2015-01-07 11:46 Tu can Note Added: 0000232
2015-01-14 10:32 johan Note Added: 0000233
2015-03-05 13:19 johan Note Added: 0000257
2015-03-05 13:19 johan Status new => resolved
2015-03-05 13:19 johan Resolution open => fixed
2015-03-05 13:19 johan Assigned To => johan